同花顺背离顶底指标公式(图文)

时间:2019-07-01 10:39:18 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

DIF:(EMA(CLOSE,12)-EMA(CLOSE,26)),colorwhite;
DEA:EMA(DIF,9),coloryellow;
macd:(DIF-DEA)*2,COLORSTICK;
死叉:=CROSS(DEA,DIF);
N1:=BARSLAST(死叉);
N2:=REF(BARSLAST(死叉),N1+1);
N3:=REF(BARSLAST(死叉),N2+N1+2);
CL1:=LLV(C,N1+1);
DIFL1:=LLV(DIF,N1+1);
CL2:=REF(CL1,N1+1);
DIFL2:=REF(DIFL1,N1+1);
CL3:=REF(CL2,N1+1);
DIFL3:=REF(DIFL2,N1+1);
PDIFL2:=IF(DIFL20,INTPART(LOG(DIFL2))-1,INTPART(LOG(-DIFL2))-1);
MDIFL2:=INTPART(DIFL2/POW(10,PDIFL2));
PDIFL3:=IF(DIFL30,INTPART(LOG(DIFL3))-1,INTPART(LOG(-DIFL3))-1);
MDIFL3:=INTPART(DIFL3/POW(10,PDIFL3));
MDIFB2:=INTPART(DIF/POW(10,PDIFL2));
MDIFB3:=INTPART(DIF/POW(10,PDIFL3));
直接底背离:=(CL1CL2 ) AND (MDIFB2MDIFL2) AND (MACD0 AND REF(MACD,1)0) AND MDIFB2=REF(MDIFB2,1);
隔峰底背离:=(CL1CL3 AND CL3CL2 ) AND (MDIFB3MDIFL3) AND (MACD0 AND REF(MACD,1)0) AND MDIFB3=REF(MDIFB3,1);
B:=(直接底背离 OR 隔峰底背离);
BG:=((MDIFB2REF(MDIFB2,1))*REF(直接底背离,1)) OR ((MDIFB3REF(MDIFB3,1))*REF(隔峰底背离,1));
STICKLINE(B OR BG,0,MACD,8,0),colorgreen;
DRAWTEXT(FILTER(BG,10),(DIF*1.5),'底'),colorred;
金叉:=CROSS(DIF,DEA);
M1:=BARSLAST(金叉);
M2:=REF(BARSLAST(金叉),M1+1);
M3:=REF(BARSLAST(金叉),M2+M1+2);
CH1:=HHV(C,M1+1);
DIFH1:=HHV(DIF,M1+1);
CH2:=REF(CH1,M1+1);
DIFH2:=REF(DIFH1,M1+1);
CH3:=REF(CH2,M1+1);
DIFH3:=REF(DIFH2,M1+1);
PDIFH2:=IF(DIFH20,INTPART(LOG(DIFH2))-1,INTPART(LOG(-DIFH2))-1);
MDIFH2:=INTPART(DIFH2/POW(10,PDIFH2));
PDIFH3:=IF(DIFH30,INTPART(LOG(DIFH3))-1,INTPART(LOG(-DIFH3))-1);
MDIFH3:=INTPART(DIFH3/POW(10,PDIFH3));
MDIFT2:=INTPART(DIF/POW(10,PDIFH2));
MDIFT3:=INTPART(DIF/POW(10,PDIFH3));
直接顶背离:=(CH1CH2 ) AND (MDIFT2MDIFH2) AND (MACD0 AND REF(MACD,1)0) AND MDIFT2=REF(MDIFT2,1);
隔峰顶背离:=(CH1CH3 AND CH3CH2 ) AND (MDIFT3MDIFH3) AND (MACD0 AND REF(MACD,1)0) AND MDIFT3=REF(MDIFT3,1);
T:=(直接顶背离 OR 隔峰顶背离);
TG:=((MDIFT2REF(MDIFT2,1))*REF(直接顶背离,1)) OR ((MDIFT3REF(MDIFT3,1))*REF(隔峰顶背离,1));
STICKLINE(T OR TG,0,MACD,8,0),colorred;
DRAWTEXT(FILTER(TG,20),(DIF*1.4),'顶'),colorgreen;

后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)